high · CVSS v3 7.5

CVE-2026-104010

The WPSyncSheets plugin for WordPress is vulnerable to remote code execution via unsanitized Contact Form 7 fields. Unauthenticated attacker

Overview

The WPSyncSheets plugin for WordPress is vulnerable to remote code execution via unsanitized Contact Form 7 fields. Unauthenticated attackers can trigger a PHP object injection chain that leads to arbitrary code execution on the server. The flaw exists in all releases up to 1.8.0.

Description

The WPSyncSheets For Contact Form 7 – CF7 Google Sheets Connector & Save to Database plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.8.0 via the 'any non-system CF7 field (e.g., your-message)' parameter parameter. This is due to insufficient sanitization of CF7 submission field values before database storage and the absence of an allowed_classes restriction on maybe_unserialize() during admin retrieval. This makes it possible for unauthenticated attackers to execute code on the server. Successful exploitation of the remote code execution gadget chain requires that a Google Sheets access token be configured in the plugin (its primary advertised feature), as this triggers autoloading of the bundled Monolog 2.10.0 library whose classes form the exploitable gadget chain; however, the underlying PHP Object Injection occurs regardless.

Impact

The vulnerability allows attackers to execute arbitrary code on the web server, compromising confidentiality, integrity, and availability of the site and any connected databases. It can lead to full site takeover, data exfiltration, and further lateral movement within the network.

Remediation

Update WPSyncSheets to the latest version (1.8.1 or newer) or remove the plugin entirely. If an update is not possible, disable the plugin, delete the Google Sheets access token, and ensure that any unserialization functions are wrapped with allowed_classes restrictions. Additionally, validate and sanitize all CF7 field inputs before storage.

Risk context

High severity (CVSS 7.5) with no EPSS data available. The flaw is exploitable by unauthenticated users, making it a critical risk for any WordPress site using the affected plugin.

Affected products

  • WordPress
  • WPSyncSheets plugin
  • Contact Form 7

Scores

Severity
high
CVSS v2
7.6
CVSS v3
7.5
CVSS v4
—
EPSS
—

wordpress plugin remote-code-execution wpsyncsheets cf7 rce high-severity

← All CVEs