high · CVSS v3 7.1
CVE-2026-104647
The weMail WordPress plugin up to version 2.1.6 fails to properly verify user capabilities in its REST API, allowing any user with a role of
Overview
The weMail WordPress plugin up to version 2.1.6 fails to properly verify user capabilities in its REST API, allowing any user with a role of Editor or higher to perform administrator‑level actions. This flaw lets attackers enumerate all registered users and their email addresses, and modify the plugin’s access‑control settings. The vulnerability can be exploited by legitimate site users with elevated roles, potentially exposing sensitive user data and compromising site configuration.
Description
The weMail WordPress plugin through 2.1.6 does not correctly verify user capabilities in its REST API permission checks, treating any user whose role is in the weMail WordPress plugin through 2.1.6's allowed-roles list (Editor and above by default) as authorised for every action, which allows such users to perform administrator-level actions including enumerating all registered users with their email addresses and modifying the weMail WordPress plugin through 2.1.6's own access-control configuration.
Impact
Confidentiality: attacker can view all registered user emails, potentially enabling phishing or credential stuffing. Integrity: attacker can alter the plugin’s access‑control configuration, potentially granting themselves higher privileges or disabling security controls. Availability: no direct impact, but configuration changes could indirectly affect site stability. Defenders are impacted if they run the affected plugin version on a WordPress site.
Remediation
1. Update the weMail WordPress plugin to version 2.1.7 or later, where the REST API permission checks have been fixed. 2. If an update is not immediately possible, restrict the allowed‑roles list in the plugin settings to only trusted administrator accounts, or remove the Editor role from the list. 3. Disable the plugin’s REST API endpoints via a firewall or .htaccess rule until a patch is applied. 4. Verify that role‑based access controls are correctly enforced by testing the REST API with a non‑admin user.
Risk context
Severity: high (CVSS v3.1 7.1). No EPSS data available. The vulnerability is exploitable by any user with Editor or higher role, making it a significant risk for sites with many such users. Defenders should prioritize patching or mitigating the issue promptly.
Affected products
- weMail WordPress plugin 2.1.6
- WordPress
Scores
- Severity
- high
- CVSS v2
- 5.5
- CVSS v3
- 7.1
- CVSS v4
- —
- EPSS
- —