medium · CVSS v3 6.4

CVE-2026-118204

The WP Data Access – App Builder plugin for WordPress is vulnerable to stored XSS via the ImageURL column value. Authenticated users with su

Overview

The WP Data Access – App Builder plugin for WordPress is vulnerable to stored XSS via the ImageURL column value. Authenticated users with subscriber-level access can inject scripts that run when others view the page. This flaw allows malicious code to execute in the context of site visitors.

Description

The WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'ImageURL column value (populated from wp_usermeta.description in the demonstrated path)' parameter in all versions up to, and including, 5.5.89 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires an administrator to have published a DataTables shortcode over a database column the attacker controls (e.g., wp_usermeta.description) with the Image URL media type assigned to that column — both are supported plugin features but are not enabled by default.

Impact

Confidentiality: attackers can steal cookies or session data via injected scripts. Integrity: malicious scripts can modify page content. Availability: not directly impacted. Defenders: site admins and users of the plugin.

Remediation

Update the WP Data Access plugin to version 5.5.90 or later. If update is not possible, disable the ImageURL column or restrict DataTables shortcode usage to trusted users. Sanitize wp_usermeta.description or use a plugin that escapes output.

Risk context

Medium severity (CVSS 6.4). No EPSS data available. Defenders should address promptly to prevent XSS exploitation.

Affected products

  • WordPress
  • WP Data Access – App Builder

Scores

Severity
medium
CVSS v2
5.5
CVSS v3
6.4
CVSS v4
—
EPSS
—

wordpress xss stored-xss wp-data-access plugin authentication defense

← All CVEs