low · CVSS v3 3.1 · CVSS v4 2.3
CVE-2026-120223
A low‑severity flaw in Oray Pugongying X5 Pro (v≤7.6.1) allows remote attackers to manipulate the _user argument in session_get, producing i
Overview
A low‑severity flaw in Oray Pugongying X5 Pro (v≤7.6.1) allows remote attackers to manipulate the _user argument in session_get, producing insufficiently random session IDs. This can lead to session prediction or hijacking. The vulnerability is publicly documented but the vendor has not released a fix.
Description
A vulnerability was identified in Oray Pugongying X5 Pro up to 7.6.1. This impacts the function session_get of the file session.lua of the component Session ID Handler. The manipulation of the argument _user leads to insufficiently random values. The attack can be initiated remotely. The attack's complexity is rated as high. The exploitability is said to be difficult. The exploit is publicly available and might be used. The vendor was contacted early about this disclosure but did not respond in any way.
Impact
The flaw compromises confidentiality, integrity, and availability of user sessions by enabling attackers to predict or forge session identifiers. Defenders should monitor for anomalous session creation patterns and enforce stricter session ID entropy. The risk is primarily to users of the affected firmware who rely on session isolation.
Remediation
Upgrade to Oray Pugongying X5 Pro firmware 7.6.2 or later once vendor releases a patch. Until then, disable remote session_get calls if possible, or enforce a server‑side session ID generator with cryptographic randomness. Apply network segmentation to limit exposure of the device to untrusted networks.
Risk context
Severity is low (CVSS 3.1) and EPSS is not available, indicating a moderate threat level. However, the vulnerability is publicly available and exploitable remotely, so defenders should treat it with caution and prioritize patching when a fix is released.
Affected products
- Oray Pugongying X5 Pro
Scores
- Severity
- low
- CVSS v2
- 2.1
- CVSS v3
- 3.1
- CVSS v4
- 2.3
- EPSS
- —