high · CVSS v3 7.8 · CVSS v4 8.5
CVE-2026-120833
Labbench versions prior to 0.46.1 deserialize untrusted .p or .pickle files using pandas.read_pickle, enabling arbitrary code execution when
Overview
Labbench versions prior to 0.46.1 deserialize untrusted .p or .pickle files using pandas.read_pickle, enabling arbitrary code execution when a user loads such files. The flaw allows attackers to run malicious code on the host system. It is a high‑severity vulnerability that can compromise confidentiality, integrity, and availability of affected installations.
Description
labbench before 0.46.1 contains a deserialization of untrusted data vulnerability in read() and read_relational() that passes any file with a .p or .pickle extension to pandas.read_pickle based on the extension alone. Attackers who supply a crafted data file or relational data archive can execute arbitrary code when a user loads it with these functions.
Impact
The vulnerability permits attackers to execute arbitrary code, potentially exfiltrating sensitive data, modifying or deleting files, and disrupting services. Users who load untrusted pickle files in Labbench are directly impacted, as are developers who rely on Labbench for data analysis workflows.
Remediation
Upgrade Labbench to version 0.46.1 or later. If upgrading is not immediately possible, disable or remove the read() and read_relational() functions that accept .p/.pickle files, or replace them with safer deserialization methods. Ensure that only trusted data sources are processed and consider using alternative formats such as JSON or CSV for data exchange.
Risk context
The CVSS v3 score of 7.8 and v4 score of 8.5 classify this as a high‑severity issue. While no EPSS data is available, the potential for arbitrary code execution warrants prompt remediation to mitigate significant risk.
Affected products
- labbench 0.46.0
- labbench <0.46.1
Scores
- Severity
- high
- CVSS v2
- 7.2
- CVSS v3
- 7.8
- CVSS v4
- 8.5
- EPSS
- —