critical · CVSS v3 9.6
CVE-2026-17396
IBM API Connect versions 10.0.8.0-10.0.8.12 and 12.1.0.0-12.1.1.2 are vulnerable to SQL injection that can be exploited by authenticated use
Overview
IBM API Connect versions 10.0.8.0-10.0.8.12 and 12.1.0.0-12.1.1.2 are vulnerable to SQL injection that can be exploited by authenticated users to retrieve sensitive data. The flaw allows attackers to bypass authentication controls and read database contents. It poses a significant risk to organizations using these API management platforms.
Description
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to SQL injection.
Impact
Confidentiality: attackers can read sensitive data from the API Connect database. Integrity: potential to modify data if injection allows. Availability: not directly impacted. Defenders: system administrators, security teams, API developers.
Remediation
Apply IBM security patch that addresses CVE-2026-17396. Upgrade to a fixed version (e.g., 10.0.8.13 or 12.1.1.3). If patch not available, restrict database access to API Connect service account, enforce least privilege, and monitor for anomalous SQL queries.
Risk context
Critical severity with CVSS 9.6 indicates high exploitation potential. Immediate patching is recommended.
Affected products
- IBM API Connect 10.0.8.x
- IBM API Connect 10.0.8.12
- IBM API Connect 12.1.0.x
- IBM API Connect 12.1.1.2
Scores
- Severity
- critical
- CVSS v2
- 8.5
- CVSS v3
- 9.6
- CVSS v4
- —
- EPSS
- —