critical · CVSS v3 9

CVE-2026-17403

IBM API Connect versions 10.0.8.0‑10.0.8.12 and 12.1.0.0‑12.1.1.2 contain hard‑coded credentials that allow a remote attacker to gain full a

Overview

IBM API Connect versions 10.0.8.0‑10.0.8.12 and 12.1.0.0‑12.1.1.2 contain hard‑coded credentials that allow a remote attacker to gain full administrative control. This flaw can be exploited over the network without authentication. It is critical because it gives attackers complete control over the API gateway and connected services.

Description

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to gain full administrative control due to the use of hard-coded credentials.

Impact

Confidentiality: All data exposed through the API gateway can be accessed. Integrity: Attackers can modify or delete API configurations and data. Availability: They can disrupt or shut down services. The primary impact is on organizations running the affected IBM API Connect versions.

Remediation

Apply the official IBM security patch or upgrade to a non‑affected version (e.g., 10.0.8.13 or 12.1.1.3). If upgrading is not immediately possible, change the default admin credentials, restrict API Connect to trusted networks, and enable network segmentation and firewall rules to block unauthorized access. Monitor authentication logs for suspicious activity.

Risk context

The vulnerability is rated critical with a CVSS v3 score of 9.0, indicating a high likelihood of exploitation and severe impact. Immediate action is recommended to mitigate potential full administrative takeover.

Affected products

  • IBM API Connect 10.0.8.x
  • IBM API Connect 12.1.0.x

Scores

Severity
critical
CVSS v2
7.6
CVSS v3
9
CVSS v4
—
EPSS
—

hard‑coded credentials remote privilege escalation IBM API Connect critical vulnerability administrative takeover

← All CVEs