critical · CVSS v3 9.9
CVE-2026-17410
IBM API Connect versions 10.0.8.0‑12 and 12.1.0.0‑12.1.1.2 are vulnerable to a remote authenticated attacker accessing and modifying other t
Overview
IBM API Connect versions 10.0.8.0‑12 and 12.1.0.0‑12.1.1.2 are vulnerable to a remote authenticated attacker accessing and modifying other tenants' portal data. The flaw arises from improper neutralization of argument delimiters, enabling cross‑tenant data leakage and tampering. This can compromise data integrity and confidentiality across multi‑tenant deployments.
Description
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to access and modify other tenants' portal data due to improper neutralization of argument delimiters.
Impact
Confidentiality: unauthorized tenant data exposure. Integrity: unauthorized modifications to portal data. Availability: not directly impacted. Defenders: multi‑tenant administrators, security teams, and users of IBM API Connect.
Remediation
Apply IBM security patch for CVE-2026-17410 (update to 10.0.8.13 or 12.1.1.3). If patch unavailable, restrict API Connect admin roles to only authorized users, enforce least privilege, isolate tenant data, and monitor for cross‑tenant access patterns.
Risk context
High urgency; critical severity indicates potential for significant data compromise. EPSS not available, but critical rating warrants immediate action.
Affected products
- IBM API Connect 10.0.8.x
- IBM API Connect 12.1.0.x
Scores
- Severity
- critical
- CVSS v2
- 9
- CVSS v3
- 9.9
- CVSS v4
- —
- EPSS
- —