high · CVSS v3 7.6

CVE-2026-17411

IBM API Connect versions 10.0.8.0-10.0.8.12 and 12.1.0.0-12.1.1.2 are vulnerable to SQL injection that can be exploited by authenticated use

Overview

IBM API Connect versions 10.0.8.0-10.0.8.12 and 12.1.0.0-12.1.1.2 are vulnerable to SQL injection that can be exploited by authenticated users. The flaw allows attackers to read, modify, or delete backend database data. This can lead to data loss, corruption, and unauthorized disclosure.

Description

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow an authenticated attacker to view, add, modify, or delete information in the back-end database due to SQL injection. Input is not properly neutralized before it is used in database queries.

Impact

Confidentiality: unauthorized data exposure. Integrity: data can be altered or deleted. Availability: potential disruption if critical data is corrupted. Defenders should monitor for anomalous DB activity and enforce least privilege.

Remediation

Apply IBM security patch for API Connect 10.0.8.12 or upgrade to 10.0.8.13/12.1.1.3. Ensure input validation and parameterized queries. Restrict authenticated user privileges and monitor logs.

Risk context

Severity high (CVSS 7.6). No EPSS data available. Immediate patching is recommended to mitigate risk of data compromise.

Affected products

  • IBM API Connect 10.0.8
  • IBM API Connect 12.1.0

Scores

Severity
high
CVSS v2
8
CVSS v3
7.6
CVSS v4
—
EPSS
—

SQL Injection IBM API Connect Data Breach High Severity Authentication Database Patch

← All CVEs