critical · CVSS v3 9.3
CVE-2026-18836
IBM API Connect versions 10.0.8.0-10.0.8.12 and 12.1.0.0-12.1.1.2 are vulnerable to server-side request forgery, allowing a remote attacker
Overview
IBM API Connect versions 10.0.8.0-10.0.8.12 and 12.1.0.0-12.1.1.2 are vulnerable to server-side request forgery, allowing a remote attacker to force the server to request arbitrary URLs and return the response. This can expose internal network resources and sensitive data. The flaw is critical with a CVSS v3 score of 9.3.
Description
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information due to server-side request forgery. The affected component can be made to send requests to unintended destinations and return the response to the attacker.
Impact
The vulnerability can compromise confidentiality by leaking internal data, affect integrity by enabling unauthorized data retrieval, and potentially disrupt availability if the server is overwhelmed. Defenders using IBM API Connect must consider the risk of internal network exposure and data exfiltration.
Remediation
Apply the latest IBM security patch for CVE-2026-18836 or upgrade to a fixed version (e.g., 10.0.8.13 or 12.1.1.3). In the interim, restrict outbound traffic from the API Connect server, enforce strict firewall rules, and disable or isolate any endpoints that can trigger SSRF.
Risk context
The issue is rated critical with a CVSS v3 score of 9.3, indicating a high likelihood of severe impact. Immediate action is recommended to mitigate potential data exposure or further exploitation.
Affected products
- IBM API Connect 10.0.8
- IBM API Connect 12.1.0
Scores
- Severity
- critical
- CVSS v2
- 8.5
- CVSS v3
- 9.3
- CVSS v4
- —
- EPSS
- —