medium · CVSS v3 4.3
CVE-2026-17211
IBM API Connect versions 10.0.8.0‑10.0.8.12 and 12.1.0.0‑12.1.1.2 are vulnerable to a remote authenticated denial‑of‑service attack caused b
Overview
IBM API Connect versions 10.0.8.0‑10.0.8.12 and 12.1.0.0‑12.1.1.2 are vulnerable to a remote authenticated denial‑of‑service attack caused by incorrect type conversion. An attacker can trigger invalid responses or service unavailability. The issue affects API management deployments that rely on these versions.
Description
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to cause a denial of service due to incorrect type conversion. A value is converted incorrectly between two different types, which could cause the service to return invalid responses or become unavailable.
Impact
The vulnerability compromises availability, potentially disrupting API traffic and service uptime. It is exploitable only by users with valid authentication, so administrators and privileged users are the primary risk group. The impact is limited to the affected API Connect instances and their downstream consumers.
Remediation
Apply the latest IBM security patch for API Connect (e.g., upgrade to 10.0.8.13 or 12.1.1.3, whichever is applicable). If upgrading is not immediately possible, restrict authenticated access to the API Connect management console, monitor for abnormal request patterns, and temporarily disable exposed APIs until a patch is applied.
Risk context
The CVSS v3 score of 4.3 indicates a medium severity risk. With no EPSS data, the urgency is moderate; defenders should prioritize patching or mitigation in line with their patch management cycle.
Affected products
- IBM API Connect 10.0.8.0‑10.0.8.12
- IBM API Connect 12.1.0.0‑12.1.1.2
Scores
- Severity
- medium
- CVSS v2
- 4
- CVSS v3
- 4.3
- CVSS v4
- —
- EPSS
- —